Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 30, 2022 - 03:01 UTC
Scheduled
We will be performing scheduled update of selected customers of File Sharing service in North America region. During the maintenance time, short service interruptions are expected.
Posted Sep 28, 2022 - 21:17 UTC
This scheduled maintenance affected: North America File Sharing (Web Portals, API, Data Transfers - Thru Server Endpoints).