Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 24, 2022 - 20:00 UTC
Scheduled
We will be performing scheduled update of File Sharing service in UK and EU regions. During the maintenance time, short service interruptions are expected.
Posted Aug 23, 2022 - 19:21 UTC
This scheduled maintenance affected: UK File Sharing (Web Portals, API, Data Transfers - Thru Server Endpoints) and EU File Sharing (Web Portals, API, Data Transfers - Thru Server Endpoints).