Domain Name Resolution Outage for Thru File Sharing service
Incident Report for Thru Inc
Resolved
This incident has been resolved.
Posted Feb 29, 2024 - 15:53 UTC
Update
We are pleased to inform that this recent service disruption has been swiftly resolved by our dedicated team. After identifying and addressing the underlying issue, normal functionality has been restored to our services.

While the problem has been rectified on our end, it's possible that some delays may persist as the fixes propagate across our network. However, we anticipate that the majority of customers can now access their File Sharing sites without any further interruption.

Should you require any assistance or have any concerns, please do not hesitate to contact us at helpcenter@thruinc.com.
Posted Feb 29, 2024 - 15:52 UTC
Monitoring
Recent service disruption has been successfully resolved. Our team has identified and addressed the underlying issue, restoring normal functionality to our services.

However, please note that while the problem has been resolved on our end, there may still be some delays as the fixes propagate across our network. We are actively monitoring the situation to ensure full recovery.
Posted Feb 29, 2024 - 13:48 UTC
Identified
We have identified the cause of this issue. We are currently working on a solution.
Posted Feb 29, 2024 - 13:28 UTC
Update
We have identified this is a DNS issue affecting our File Sharing customers. Some File Sharing sites may be available as this global DNS issue resolves.
Posted Feb 29, 2024 - 12:17 UTC
Update
We are continuing to investigate this issue.
Posted Feb 29, 2024 - 12:08 UTC
Update
We are continuing to investigate this issue.
Posted Feb 29, 2024 - 11:57 UTC
Investigating
Currently we are investigating a DNS issue affecting all File Sharing sites in all regions.
Posted Feb 29, 2024 - 11:54 UTC
This incident affected: North America File Sharing (Web Portals, API, Data Transfers - Thru Server Endpoints), UK File Sharing (Web Portals, API, Data Transfers - Thru Server Endpoints), EU File Sharing (Web Portals, API, Data Transfers - Thru Server Endpoints), APAC File Sharing (Web Portals, API, Data Transfers - Thru Server Endpoints), and File Sharing - Pre-production Environment (Web Portals, API, Data Transfers - Thru Server Endpoints).