File Delivery Delays (US Region)

Incident Report for Thru Inc

Resolved

This incident has been resolved.
Posted Sep 02, 2025 - 13:37 UTC

Update

Engineering has been monitoring the issue and has determined that the issue is fully resolved.

If you experience any file delivery issues, please contact helpcenter@thruinc.com for assistance.

Thank you for your patience,
The Boomi MFT - AFT Team
Posted Sep 02, 2025 - 13:36 UTC

Update

The fix has been successfully deployed and is working. Our platform is now recovering and processing the queue of delayed files. While the system catches up, some files may still experience delivery delays. We are monitoring the situation closely and expect all services to return to normal shortly.
Posted Sep 02, 2025 - 13:23 UTC

Update

We are continuing to monitor for any further issues.
Posted Sep 02, 2025 - 13:13 UTC

Update

We are continuing to monitor for any further issues.
Posted Sep 02, 2025 - 13:12 UTC

Monitoring

A fix has been implemented and we are currently monitoring the results to ensure the issue is resolved.
Posted Sep 02, 2025 - 13:10 UTC

Update

We are continuing to work on a fix for this issue.
Posted Sep 02, 2025 - 12:44 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 02, 2025 - 12:37 UTC

Investigating

Customers in the US region may experience delays in file delivery due to a recent service interruption caused by a temporary storage resource constraint on a core messaging service. We have identified the issue and are implementing a solution.
Posted Sep 02, 2025 - 12:36 UTC
This incident affected: North America Automated File Transfer (API, Data Transfers - External Server Endpoints, Data Transfers - Thru Server Endpoints).